PDA

View Full Version : 4500 output plug does not fit my hose couplings....



davee1
04-02-2011, 05:04 AM
Got my 4500 Shoebox compressor today, serial # 405.

I was under the impression that the output plug would mate up with #12 Foster and Hansen female sockets.
I've got two fill hoses, one uses a #12 female foster socket, and the other uses a Hansen LL1-ST female socket.
The problem is, neither socket works on the output plug on my Shoebox, they seem too big.
The hoses hook right up to my Marauders fill plug...been using them for months.

***EDIT***
seems ok now. User Error???

davee1
04-02-2011, 06:36 AM
Ummmm....nevermind guys....although the fitting seems loose, it does hold air up to 3000psi.
Maybe there was some crud on my hose fittings? I dont know. Seems to be working now

TomKaye
04-02-2011, 03:41 PM
Glad to hear you got it solved.

Tom

Gabby
04-03-2011, 03:12 AM
Got mine 2 days ago [#407] and hooked small water separater and filter then small harbor freight dessicant filter at shoebox. We live in high humidity area [southeast texas] and I wanted to keep water out cause water does not compress.Had small fan blowing on cylinders [heat is enemy] and only got slighty warm to the touch during a 2 hr fill.[80 cf scuba tank from 2450 to 3000] No leaks or problems whatsoever.I also turned it off twice and lubed shafts.This thing is a marvel of engineering.Kudos to Tom for inventing something that changed the world for air gunners and paint ballers.I think that with TLC this thing will give many years of service. After the 2 hrs pumping, about one quarter of the crystals had turned pink and had about quarter teaspoon of water in craftsmen compressor tank when I drained it.I think it is very important to keep water and heat out of a small compressor like this. Could be why some people had some trouble.Time will tell. Hope to see you in Arkansas Tom.